Fixing the blank developer settings on SlimRoms Nougat

After building SlimRoms Nougat for the H811 (LG G4 T-Mobile), I ran into an odd artifact: when you enabled and opened the developer settings, it would be blank, or crash. I had absolutely no idea why that would be, nor where to begin looking into a fix.

So, I hopped over to SlimRoms’ gerrit: https://review.slimroms.org/#/q/status:merged

Once there, I looked at merged (accepted or fixed) labels, and typed “developer” in the search box. A lot of things came up, but there was a noticeable trend among the contenders, a crash or ANR report when opening the developer settings.

In every case they used the same fix, so I decided to give it a try. It looks like the common factor in every case was the FRP, or factory reset protection in the system.prop files for the devices. I took a look at mine:

# Factory Reset Protection
PRODUCT_PROPERTY_OVERRIDES += \
ro.frp.pst=/dev/block/bootdevice/by-name/persistent

and edited them as such (just commented out) :

# Factory Reset Protection
# PRODUCT_PROPERTY_OVERRIDES += \
# ro.frp.pst=/dev/block/bootdevice/by-name/persistent
# WJH commented out as this prevents the developer options from opening.

And it was fixed! It’s great when the fix is so easy!

Linux – keep it simple!

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s