Compile SlimRoms 6.0 for the Samsung Galaxy S4 T-mobile variant (JFLTETMO SGH-M919)

By all acounts it was a happy sight to see the below in my terminal:

[CODE]
using prebuilt boot.img from BOOTABLE_IMAGES…
boot size (6862848) is 65.45% of limit (10485760)
running: openssl pkcs8 -in build/target/product/security/testkey.pk8 -inform DER -nocrypt
running: java -Xmx2048m -jar /home/alaskalinuxuser/Documents/projects/phones/compile/slimroms6/out/host/linux-x86/framework/signapk.jar -w build/target/product/security/testkey.x509.pem build/target/product/security/testkey.pk8 /tmp/tmp2XWker /home/alaskalinuxuser/Documents/projects/phones/compile/slimroms6/out/target/product/jfltetmo/slim_jfltetmo-ota-96a735f156.zip
done.
_______________________________________________
/ http://www.slimroms.org |
/ _____________________________________________|
/ /
/ / _ _ ______
/ / | |(_) (_____ \
/ / | | _ _____ _____) )___ _____ ___
_____________________/ / | || | | __ // _ \| |/___)
| / | || | | | | | \ \ |_| | | | |___ |
|_______________________/ \_)_|_|_|_|_| |_\___/|_|_|_(___/

Package Complete: /home/alaskalinuxuser/Documents/projects/phones/compile/slimroms6/out/target/product/jfltetmo/Slim-jfltetmo-6.0.1.alpha.0.1-UNOFFICIAL-20160516-0840.zip
make: Leaving directory `/home/alaskalinuxuser/Documents/projects/phones/compile/slimroms6′

#### make completed successfully (08:20:24 (hh:mm:ss)) ####
[/CODE]

Unfortunately, a test of the rom proved it to fail. This is not the first time that I have built “successfully” and yet had a failure to run properly. There are several possible reasons, which I plan to look into, and hopefully take action on.

1. One of the items that I commented out or changed during the failures to compile was not the proper course of action.
Most definately, I lack in knowledge about such things as programming and code, and have incorrectly solved one of the compiling problems by ultimately making a “dud” build.

2. There is some problem with the vendor blobs, or the copying/loading/linking to them.
It is possible that there is some issue with the vendor blobs or the use thereof, as in the past I have frequented this problem with “successful” builds that did not successfully run.

3. There is something wrong with SlimRoms 6.0 source when building for this or all devices.
Since SlimRoms is calling SlimMM (SlimRoms 6.0) an alpha stage, it is quite possible that some needed files, dependencies, or otherwise useful items are not yet fully functional. There would be little to no way to test this, but the idea has merrit.

The three options above are listed by what I feel is thier likely-hood of being true. While #1 should be my first look, #2, the vendor blobs, is really easy to swap out with others, so I am going to tackle that first. I orriginally put SlimLP’s vendor blobs in there, but this time, put in CM13’s vendor blobs from my previously successful build. Let’s see if that helps.

Linux – Keep it simple.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s